6.5. Adding nodes to your Node Library

You can expand the things that Vuo can do, or save yourself the work of creating the same composition pieces over and over, by adding nodes to your Node Library.

6.5.1. Creating your own node

One way to add a new node to your Node Library is by building a composition out of existing nodes and using File > Save Composition to Node Library or File > Move Composition to Node Library. See the section on Working with subcompositions.

Another option is to implement a new node with text programming, using Vuo’s API. See Developing Node Classes and Types for Vuo.

6.5.2. Installing a node

Other people in the Vuo community have created nodes that you can download and install. Once you’ve downloaded a subcomposition file (.vuo) or node file (.vuonode), you can install it with the following steps.

First, place the file in one of Vuo’s Modules folders. Subcomposition files can only be installed in the User Modules folder, while node files can be installed in either the User Modules or the System Modules folder. You can get to these folders via menu items in the Editor:

  • Tools > Open User Modules Folder

    • Or, if you’d rather find the folder yourself: In your home folder, go to Library/Application Support/Vuo/Modules. (On Mac OS X 10.7 and above, the Library folder is hidden by default. To find it, go to Finder, then hold down the Option key and select the Go > Library menu option.)

  • Tools > Open System Modules Folder

    • Or, if you’d rather find the folder yourself: In the top-level folder on your hard drive, go to Library/Application Support/Vuo/Modules.

For node files, you’ll typically want the User Modules folder, since yours will be the only user account on your computer that needs access to the node. Use the second option only if you have administrative access and you want all users on the computer to have access to the node.

Second, restart the Vuo Editor. The node should now show up in your Node Library.