2.6. How to learn more

There are different ways to learn about Vuo, depending on how you learn best. You can read more of the manual, watch tutorials, or open example compositions in the Vuo Editor File > Open Example.

2.6.1. Example compositions

Examples are arranged by the node set they help explain, such as vuo.image or vuo.math. From File > Open Example in the Vuo Editor, you can hover over a node set to see relevant examples. Hovering over vuo.color, for example, will display the example composition, Explore Color Schemes. Clicking on an example composition will open it in the Vuo Editor. Alternately, if you know the title of an example composition, you can use the Help > Search box to search for words within the composition title.

To learn more about an example composition, look at the Editor’s Node Documentation Panel. This displays the composition’s description, which includes instructions on how you can interact with it.

To see a list of descriptions for all example compositions for a node set, look in the node set documentation. In the Editor’s Node Library (Window > Show Node Library), find a node that belongs to that node set. For example, to learn more about the vuo.math example compositions, use the keyword math in the Node Library search window to find the nodes in that node set, or click on a node in the library that contains math in its class name. You can see class names by using View > Node Library > Display by class. Clicking on any node in the node set will show that node’s description in the Node Documentation Panel. The description will contain a link to the node set documentation. Using that link will display some general information about that node set, as well as descriptions of the associated example compositions.

More examples are available in the Vuo composition gallery. You can filter compositions in the gallery by using the tabs. The Helpful tab contains compositions other users have voted helpful.

Many of the compositions illustrated in this manual are provided as example compositions in the Editor. These are indicated with a menu path to the example composition, such as File > Open Example > vuo.motion > Wave Circle.