Exporting an FxPlug plugin

New in Vuo 2.0

You can turn your Vuo compositions into custom effects, transitions, and generators for Final Cut Pro X and Motion.

Video effects

  • In Vuo, go to File > New Composition from Template > Export > FxPlug > Effect. This creates a composition that conforms to the Image Filter protocol.

  • Add nodes to the composition to make it alter the input image and output the result.

  • Go to File > Export > FxPlug.

  • When the export is complete, relaunch Final Cut Pro.

  • In Final Cut Pro, find the plugin in the Effects Browser under Video > Vuo.

Transitions

  • In Vuo, go to File > New Composition from Template > Export > FxPlug > Transition. This creates a composition that conforms to the Image Transition protocol.

  • Add nodes to the composition to make it combine the input images and output the result.

  • Go to File > Export > FxPlug.

  • When the export is complete, relaunch Final Cut Pro.

  • In Final Cut Pro, find the plugin in the Transitions Browser under Vuo.

Generators

  • In Vuo, go to File > New Composition from Template > Export > FxPlug > Generator. This creates a composition that conforms to the Image Generator protocol.

  • Add nodes to the composition to make it output a stream of images.

  • Go to File > Export > FxPlug.

  • When the export is complete, relaunch Final Cut Pro.

  • In Final Cut Pro, find the plugin in the Titles and Generators sidebar under Vuo.

Category and name

By default, plugins exported from Vuo are installed in Final Cut Pro under the Vuo category. To choose a different category, before exporting go to Edit > Composition Information…, click on the Exporting tab, and enter an FxPlug Group.

In Edit > Composition Information…, under the General tab, you can change the name of the plugin displayed in Final Cut Pro.

Parameters

When creating a composition to be exported as an FxPlug, the composition will have the published ports required by the protocol. It may also include some of the optional published ports for FxPlug listed in Making compositions fit a mold with protocols.

You can add non-protocol published input ports as well. These appear in the Inspector panel in Final Cut Pro.

Non-protocol published input ports with the following data types are controllable in Final Cut Pro or Motion:

Data type Notes
Real
2D Point
3D Point
4D Point
Integer
Boolean
Text
Color
Image Available in Motion but not Final Cut Pro
Option types Data values edited in Vuo using menus

Published input ports that have menu input editors in Vuo may behave the same or differently in Final Cut Pro, depending on the port’s data type. You can check the port’s data type by clicking on the port to open its popover. If the data type is something other than Integer — for example, the Blend Mode type of the Blend Images node’s Blend Mode port — then Final Cut Pro will present a menu. If the data type is Integer, then Final Cut Pro will present a slider to select by number, with 0 corresponding to the first menu item.

You can adjust the default, minimum, and maximum values for a parameter in Final Cut Pro by editing the published input port in Vuo. Right-click on the published input port and select Edit Value… to change the default value or Edit Details… to change the minimum and maximum.

Sharing plugins

You can share FxPlug plugins you’ve created in Vuo with other people, even if they don’t have Vuo. There are two files associated with a plugin. To find them:

  • FxPlug file

    • In Finder, hold down and go to Go > Library.

    • In that folder, navigate to Plug-Ins > FxPlug.

    • Locate the plugin (a .fxplug file).

  • Motion template

    • In Finder, go to Go > Home.

    • In that folder, navigate to Movies > Motion Templates.

    • Within the Effects, Generators, or Transitions folder, locate the file for your plugin.

You can send these two files to someone else, who can install them in the same location on their computer. Both files are needed for the plugin to work.

Uninstalling plugins

To uninstall a plugin that was exported from Vuo:

  • Quit Final Cut Pro and Motion.

  • Locate the two files described in the previous section, and throw them in the Trash.