Working with subcompositions

Abstract

Installing, editing, and uninstalling subcompositions

With a subcomposition, you can use a composition as a node within other compositions. For more on what subcompositions are and why to use them, see Using subcompositions inside of other compositions.

Installing a subcomposition

To turn part of an existing composition into a subcomposition, select those nodes and cables within the composition, then go to the Edit > Package as Subcomposition menu item.

To turn an entire composition into a subcomposition, create or open the composition and select the File > Move to User Library menu item. (If your composition has not yet been saved, the menu item will read Save to User Library, and you’ll be prompted to enter a title for your node.) The subcomposition node will immediately be listed and highlighted within your Node Library for use within other compositions.

To insert an empty subcomposition into a composition, select the Edit > Insert Subcomposition menu item.

To install a subcomposition that you’ve downloaded, see Installing a node.

Editing a subcomposition

There are several ways to edit a subcomposition after it has already been installed:

  • Right-click on the subcomposition node, either within the Node Library or on the canvas, and select the Edit Composition… context menu item.

  • Double-click on the body of the node on the canvas.

  • Select the node on the canvas and press ⌘↓.

  • Click the Edit Composition… link in the node library documentation panel.

Uninstalling a subcomposition

To remove an installed subcomposition, right-click on the subcomposition node within the Node Library and select the Show in Finder context menu item. Locate the .vuo file matching the name of your subcomposition and remove it from the folder.